Legend

(question): Candidate (ACS Medium/Long Term Plan)

(info): Proposed (SCCB Created)

(warning): Approved (SCCB Approved)

(tick): Done (Implemented in Release)

(error): Rejected (SCCB Rejected / Technical Issues Prevented Change)

Obsolescence Plan

NameReleaseOriginalNewStatusTicketComment
Boost2020OCT1.601.66(tick)

Upgrading to same version as RHEL 8 Boost. Aiming to depend on O.S. version in the future.
xercesc2020OCT2.8.03.2.2(tick)

Upgrading to same version as RHEL 8 xerces-c. Aiming to depend on O.S. version in the future.
numpy2020OCT1.15.1-(tick)

Removing duplicate dependency
gcovr2020OCTLatest4.2(tick)

Change open version to use latest available at the time (2020-08-13)
pexpect2020OCTLatest4.8.0(tick)

Change open version to use latest available at the time (2020-08-13)
psutil2020OCTLatest5.7.2(tick)

Change open version to use latest available at the time (2020-08-13)
test-generator2020OCTLatest0.1.2(tick)

Change open version to use latest available at the time (2020-08-13)
ACE/TAO2020DEC6.4.36.5.11(info)

Upgrading to latest version would allow removal of Mico
Mico2020DEC2.3.13Removed(info)

Only used for IDL syntax checking, which latest version of TAO also provides
log4cpp2020DEC0.3.4bRemove(question)

Only used for an alternative logger that never made it into production and library is no longer being developed.
cppunit2020DEC1.12.11.14.0(info)

Upgrading to same version as RHEL 8 cppunit. Aiming to depend on O.S. version in the future.
PyEnv2020DECLatest1.2.21(tick)

Change open version to use latest available at the time (2020-10-20)
pip2020DECUnfixed20.2.4(tick)

Change open version to use latest available at the time (2020-10-20)
OmniORBpy2021FEB4.2.34.3.0(question)
Upgrade to be aligned with latest version
Tcl/Tk2021FEB8.5.198.6.8(question)
Upgrading to same version as RHEL 8 cppunit. Aiming to depend on O.S. version in the future.
castor2021FEB0.9.61.4.1(question)
Obsolescence Management (2002-2005).
jakarta-oro2021FEB2.0.52.0.8(question)
Obsolescence Management (2002-2005).
jakarta-regexp2021FEB1.21.4(question)
Obsolescence Management (2002-2005).
jdom2021FEB1.02.0.2(question)
Obsolescence Management (2002-2005).
mail2021FEB1.31.6.2(question)
Obsolescence Management (2002-2005).
prevayler2021FEB1.02.0012.6(question)
Obsolescence Management (2002-2005).
relaxng-datatype2021FEB200204142.3.3(question)
Obsolescence Management (2002-2005).
babel2021FEB1.32.8.0(question)
Obsolescence Management (2013-2014).
jinja22021FEB2.732.11.2(question)
Obsolescence Management (2013-2014).
markupsafe2021FEB0.231.1.1(question)
Obsolescence Management (2013-2014).
argparse2021FEB1.3.01.4.0(question)
Obsolescence Management (2013-2014).
coverage2021FEB

3.7.1

5.2.1(question)
Obsolescence Management (2013-2014).
docutils2021FEB0.120.16(question)
Obsolescence Management (2013-2014).
logilab-common2021FEB0.63.21.7.2(question)
Obsolescence Management (2013-2014).
snowballstemmer2021FEB1.2.02.0.0(question)
Obsolescence Management (2013-2014).
astyle2021APR1.15.33.1(question)
Upgrading to same version as RHEL 8 cppunit. Aiming to depend on O.S. version in the future.
doxygen2021APR1.12.11.14.0(question)
Upgrading to same version as RHEL 8 cppunit. Aiming to depend on O.S. version in the future.
graphviz2021APR1.2.131.8.14(question)
Upgrading to same version as RHEL 8 cppunit. Aiming to depend on O.S. version in the future.
activation2021APR1.11.1.1(question)
Obsolescence Management (2006-2008).
antlr2021APR3.0.1

3.5.2

4.8.1

(question)
Obsolescence Management (2006-2008).
commons-jexl2021APR1.1.2.1.1(question)
Obsolescence Management (2006-2008).
java-getopt2021APR1.0.121.0.13(question)
Obsolescence Management (2006-2008).
jfcunit2021APR2.0.62.0.8(question)
Obsolescence Management (2006-2008).
vtd-xml2021APR2.42.13.4(question)
Obsolescence Management (2006-2008).
xalan2021APR2.7.02.7.2(question)
Obsolescence Management (2006-2008).
xalan-serializer2021APR2.7.02.7.2(question)
Obsolescence Management (2006-2008).
pygments2021APR2.0.22.6.1(question)
Obsolescence Management (2015).
sphinx2021APR1.3.13.2.0(question)
Obsolescence Management (2015).
alabaster2021APR0.7.30.7.12(question)
Obsolescence Management (2015).
ephem2021APR3.7.6.03.7.7.1(question)
Obsolescence Management (2015).
hiredis2021APR0.2.01.1.0(question)
Obsolescence Management (2015).
pytz2021APR2015.22020.1(question)
Obsolescence Management (2015).
sphinx-rtd-theme2021APR0.1.70.5.0(question)
Obsolescence Management (2015).
unittest22021APR1.0.11.1.0(question)
Obsolescence Management (2015).
expat2021JUN1.95.32.2.5(question)
Upgrading to same version as RHEL 8 cppunit for consistency as O.S version is already being used except in LCUs
log4cpp2021JUN0.3.4bRemove?(question)
Only used for an alternative logger that never made it into production and library is no longer being developed.
shunit22021JUN2.1.52.1.7(question)
Obsolescence Management.
commons-beanutils2021JUN1.8.31.9.4(question)
Obsolescence Management (2009-2010).
commons-cli2021JUN1.21.4(question)
Obsolescence Management (2009-2010).
commons-digester2021JUN2.13.2(question)
Obsolescence Management (2009-2010).
commons-io2021JUN2.02.7(question)
Obsolescence Management (2009-2010).
commons-lang2021JUN2.53.11(question)
Obsolescence Management (2009-2010).
commons-math2021JUN2.13.6.1(question)
Obsolescence Management (2009-2010).
objenesis2021JUN1.23.1(question)
Obsolescence Management (2009-2010).
trilead-ssh22021JUN2.132.22(question)
Obsolescence Management (2009-2010).
xmlunit2021JUN1.31.6(question)
Obsolescence Management (2009-2010).
twisted2021JUN18.7.020.3.0(question)
Obsolescence Management (2017-2018).
futures2021JUN3.1.13.3.0(question)
Obsolescence Management (2017-2018).
h5py2021JUN2.7.02.10.0(question)
Obsolescence Management (2017-2018).
redis2021JUN2.10.63.5.3(question)
Obsolescence Management (2017-2018).
requests2021JUN2.13.02.24.0(question)
Obsolescence Management (2017-2018).
simplejson2021JUN3.13.23.17.2(question)
Obsolescence Management (2017-2018).
suds-py32021JUN1.3.3.01.4.1.0(question)
Obsolescence Management (2017-2018).
tornado2021JUN4.5.26.0.4(question)
Obsolescence Management (2017-2018).
hamcrest-core2021AUG1.32.2(question)
Obsolescence Management (2010-2015).
hamcrest-library2021AUG1.32.2(question)
Obsolescence Management (2010-2015).
hsqldb2021AUG2.3.32.5.1(question)
Obsolescence Management (2010-2015).
junit2021AUG4.114.13(question)
Obsolescence Management (2010-2015).
junit-dep2021AUG4.104.11(question)
Obsolescence Management (2010-2015).
mockito-core2021AUG1.9.53.4.6(question)
Obsolescence Management (2010-2015).
mysql-connector-java2021AUG5.1.208.0.21(question)
Obsolescence Management (2010-2015).
sqltool2021AUG2.3.32.5.1(question)
Obsolescence Management (2010-2015).
testng2021AUG5.87.3.0(question)
Obsolescence Management (2010-2015).
astroid2021AUG2.0.42.4.2(question)
Obsolescence Management (2018-2019).
gnuplotlib2021AUG0.220.33(question)
Obsolescence Management (2018-2019).
ipython2021AUG7.8.07.17.0(question)
Obsolescence Management (2018-2019).
pylint2021AUG2.1.12.5.3(question)
Obsolescence Management (2018-2019).
pyopenssl2021AUG18.0.019.1.0(question)
Obsolescence Management (2018-2019).
pysnmp2021AUG4.4.54.4.12(question)
Obsolescence Management (2018-2019).
python-ldap2021AUG3.1.03.3.1(question)
Obsolescence Management (2018-2019).
scipy2021AUG1.1.01.5.2(question)
Obsolescence Management (2018-2019).
hibernate2021OCT5.3.75.4(question)
Obsolescence Management (2017-2019).
jaxb-impl2021OCT2.3.22.3.3(question)
Obsolescence Management (2017-2019).
jaxb-xjc2021OCT2.3.22.3.3(question)
Obsolescence Management (2017-2019).
json2021OCT2018013020200518(question)
Obsolescence Management (2017-2019).
kafka-clients2021OCT2.2.02.6.0(question)
Obsolescence Management (2017-2019).
openjdk-orb-jdk9-supplement2021OCT1.0.11.0.3(question)
Obsolescence Management (2017-2019).
pfl-basic2021OCT4.0.14.1.0(question)
Obsolescence Management (2017-2019).
xercesj2021OCT2.12.02.12.1(question)
Obsolescence Management (2017-2019).
lxml2021OCT4.4.14.5.2(question)
Obsolescence Management (2019-2020).
matplotlib2021OCT3.1.13.3.0(question)
Obsolescence Management (2019-2020).
mock2021OCT3.0.54.0.2(question)
Obsolescence Management (2019-2020).
numpy2021OCT1.18.11.19.1(question)
Obsolescence Management (2019-2020).
setuptools2021OCT40.2.049.3.1(question)
Obsolescence Management (2019-2020).
six2021OCT1.14.01.15.0(question)
Obsolescence Management (2019-2020).